/ Browser Requirements

TRIAX® Web Viewer Browser Compatibility (Desktop)
Browser: IE IE Edge Chrome FireFox Safari
Version: ≥ 10.0 ≤ 9.X All ≥ 4.0 ≥ 2.0 ≥ 3.1
Supported:

Note for Windows XP Users

If using Internet Explorer (IE) on Windows XP, and unable to install one of the browsers listed above, please try the following:

  1. Download portable web browser (no installation) → Download Chrome Portable
  2. Run downloaded file and extract to location chosen
  3. Open extracted folder, and run GoogleChromePortable.exe
  4. Go to Triax home page